Benjamin LaHaise wrote on Friday, October 13, 2006 7:23 AM
> On Thu, Oct 12, 2006 at 05:00:24PM -0700, Chen, Kenneth W wrote:
> > A clean up patch: I think it is a lot easier to read AIO_EVENTS_OFFSET
> > as an offset because of aio_ring at the beginning of a head page, instead
> > of doing arithmetic of (event on 2nd page - event on 1st page).
>
> Nak. Your change fails if aio_ring is not an exact multiple of the
> io_event size due to rounding errors, while the original code rounds
> correctly.
Yeah, neither form is bullet proof, even the original one will break down
when io_event size is not in power of 2. The good news is that no where
near in sight that these two data structures size will change.
To make it a real bullet proof, it should be something like the following:
#define AIO_EVENTS_OFFSET ((sizeof(struct aio_ring) + \
sizeof(struct io_event) - 1 ) / \
sizeof(struct io_event))
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]