Re: [PATCH] rename net_random to random32

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Oct 12, 2006 at 10:26:38AM -0700, Stephen Hemminger wrote:
> 
> Make net_random() more widely available by calling it random32
>...
> --- a/lib/Makefile
> +++ b/lib/Makefile
> @@ -5,7 +5,7 @@ #
>  lib-y := ctype.o string.o vsprintf.o cmdline.o \
>  	 bust_spinlocks.o rbtree.o radix-tree.o dump_stack.o \
>  	 idr.o div64.o int_sqrt.o bitmap.o extable.o prio_tree.o \
> -	 sha1.o irq_regs.o carta_random32.o
> +	 sha1.o irq_regs.o random32.o carta_random32.o
>...
> --- /dev/null
> +++ b/lib/random32.c
>...
> +EXPORT_SYMBOL(random32);
>...
> +EXPORT_SYMBOL(srandom32);
>...

EXPORT_SYMBOL's in lib-y are latent bugs (IMHO kbuild should error
on them):

The problem is that if only modules use these functions, they will be 
omitted from the kernel image.

cu
Adrian

-- 

       "Is there not promise of rain?" Ling Tan asked suddenly out
        of the darkness. There had been need of rain for many days.
       "Only a promise," Lao Er said.
                                       Pearl S. Buck - Dragon Seed

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux