On 10/12/06, Andrew Morton <[email protected]> wrote:
Meanwhile, from a quick scan I'd say that unionfs is much, much too lightly
commented for a review to be particularly effective. Please work on that.
Could use some basic coding style fixes too.
- Move assignments outside of if statement expression "if (err = foo_bar())"
- No C99-style comments "//"
- Use struct kmem_cache instead of the deprecated kmem_cache_t
- Don't use function-like macros as the left hand side of assignment
expression "itohi_ptr(inode) = kzalloc(size, GFP_KERNEL);". It's much
better to open-code the assignment or introduce a setter function
(e.g. inode_set_hiptr).
- Kill wrappers (e.g. unionfs_kill_block_super can be replaced with
generic_shutdown_super)
Pekka
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]