On Thu, 12 Oct 2006 16:43:07 +0900
Akinobu Mita <[email protected]> wrote:
> From: Akinobu Mita <[email protected]>
>
> This patch provides base functions for implement fault-injection
> capabilities.
>
> - Lightweight random simulator is taken from crasher module for SUSE kernel
heh, another one.
Please switch over to carta_random32() for now. Later we'll probably be
removing carta_random32() and adding random32(), but I can take care of
that.
> +#define failure_probability(attr) (attr)->probability
> +#define failure_interval(attr) (attr)->interval
> +#define max_failures(attr) (attr)->times
> +#define current_space(attr) (attr)->space
> +#define atomic_dec_not_zero(v) atomic_add_unless((v), -1, 0)
Please remove these macros and simply open-code these operations at each
callsite.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]