Quoting Eric W. Biederman ([email protected]):
> To avoid pid rollover confusion the kernel needs to work with
> struct pid * instead of pid_t. Currently there is not an iterator
> that walks through all of the tasks of a given pid type starting
> with a struct pid. This prevents us replacing some pid_t instances
> with struct pid. So this patch adds do_each_pid_task which walks
> through the set of task for a given pid type starting with a struct pid.
>
> Signed-off-by: Eric W. Biederman <[email protected]>
> ---
> include/linux/pid.h | 13 +++++++++++++
> 1 files changed, 13 insertions(+), 0 deletions(-)
>
> diff --git a/include/linux/pid.h b/include/linux/pid.h
> index 93da7e2..4007114 100644
> --- a/include/linux/pid.h
> +++ b/include/linux/pid.h
> @@ -118,4 +118,17 @@ #define while_each_task_pid(who, type, t
> 1; }) ); \
> }
>
> +#define do_each_pid_task(pid, type, task) \
Hmm, defining do_each_pid_task right after do_each_task_pid could result
in some frustration :)
Though not sure of a better name - do_each_task_structpid?
-serge
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]