Some comments from a MMC/SD perspective.
On a general note, please replace all your constants with defines. Magic
values are no fun (unless they are in fact a magic number ;)).
Also, calling the struct "card" might be a bit misleading as it might be
a bus in the MMC case.
In tifm_sd_o_flags(), try not to case on response types as the hardware
shouldn't have to care about this. If you really, really, _really_ must
do this, then make sure you have a default that prints something nasty
and fails the request with an error.
A default is also needed for cmd_flags in the same function.
In tifm_sd_exec(), you should only need to test for the presence of
cmd->data, not that the command is of ADTC type.
Rgds
Pierre
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]