set_wmb(var, value) is not used anywhere in the kernel. And it doesn't
do anything special but shorten the typing of:
var = value;
wmb();
Which the above is much more readable, and thus set_wmb is just
something to confuse developers even more.
So this patch series removes set_wmb from the kernel. It's not
currently used in the kernel, and any out-of-kernel branch can easily
replace it. So there should be no harm in removing it.
The first patch removes it from Documentation/memory-barriers.txt and
the second patch does a sweep through all the architectures to get rid
of it. All archs do the above code except ia64 and sparc which do a
mb() instead. But regardless, it's still not used.
-- Steve
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]