Re: [patch] cleanup: kthread workqueue rename

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Thu, Jun 22, 2006 at 04:13:16AM -0700, Andrew Morton wrote:
> On Thu, 22 Jun 2006 16:29:12 +0800
> Coywolf Qi Hunt <[email protected]> wrote:
> > -static struct workqueue_struct *helper_wq;
> > +static struct workqueue_struct *kthread_wq;
> "helper" is better.  It's there to help kthread launching and that's all it
> does.  So "helper" is a more specific identification.

So "khelper_wq" should better be "helper_wq" too?

    khelper_wq = create_singlethread_workqueue("khelper");

'helper_wq' becomes [kthread] as shown in ps ax; I don't think it is a 'helper'.

    5 ?        S<     0:00 [khelper]
    6 ?        S<     0:00 [kthread]

That vague name makes me easily forget what I am looking at.  Please apply.

Coywolf Qi Hunt
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at
Please read the FAQ at

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux