On Tue, 2006-06-13 at 19:54 -0500, Chase Venters wrote:
> On Tuesday 13 June 2006 18:54, Matt Helsley wrote:
>
> > +static void cn_proc_fini(void)
> > +{
> > + int err;
> > +
> > + err = unregister_task_watcher(&cn_proc_nb);
> > + if (err != 0)
> > + printk(KERN_WARNING
> > + "cn_proc failed to unregister its task notify block\n");
>
> How about if (err), or if (unregister_task_watcher(&cn_proc_nb))?
I don't see any worthwhile benefit to the former and I've seen feedback
that the latter is less readable.
> > + cn_del_callback(&cn_proc_event_id);
> > +}
> > +
> > module_init(cn_proc_init);
> > +module_exit(cn_proc_fini);
>
> Thanks,
> Chase
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]