Re: [stable] [PATCH] sbp2: fix check of return value of hpsb_allocate_and_register_addrspace

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Andrew Morton wrote:
On Sat, 03 Jun 2006 11:31:27 +0200
Andreas Schwab <[email protected]> wrote:
Michael Tokarev <[email protected]> writes:
* Stefan Richter ([email protected]) wrote:
-    if (!scsi_id->status_fifo_addr) {
+    if (scsi_id->status_fifo_addr == ~0ULL) {

Umm.  Can this ~0ULL constant be #define'd to something?
It's way too simple to mis-read it as NULL (or ~NULL whatever).

How about writing it as -1?

That's preferable.

It doesn't actually cause a problem, but status_fifo_addr is defined as
u64, which is not `unsigned long long'.  On powerpc, for example, u64 is
implemented as unsigned long.  -1 just works.

I have a patch ready which replaces the magic value by a sensibly named preprocessor constant. Will be posted within the hour. Thanks for the comments.
--
Stefan Richter
-=====-=-==- -==- ---==
http://arcgraph.de/sr/
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux