Re: 2.6.17-rc4-mm1 panic on boot

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, May 16, 2006 at 01:45:38AM -0700, H. Peter Anvin wrote:
> Followup to:  <[email protected]>
> By author:    [email protected]
> In newsgroup: linux.dev.kernel
> >
> > Just upgraded from rc3-mm4.
> > Panic on boot with this message (copied by hand ):
> > 	kinit:do_mount
> > 	kinit: name_to_dev_t(/dev/hda8) = dev (0,0)
> > 	kinit:rot_dev = dev (0,0)
> > 	kinit root_dev = dev (0,0)
> > 	kinit trying to mount /dev/root on /root
> > 	...........
> > /dev/hda8 is my root partition but I suppose dev (0,0) is the first
> > partition on hda which is FAT.
> > I tried vanilla rc4 with the same result.
> > 
> 
> This means kinit couldn't find a name-to-number mapping for the string
> /dev/hda8.  However, you said you tried vanilla rc4 with the same
> result, and vanilla rc4 doesn't use klibc.
Sorry for my silliness, actually rc4 boot OK
> 
> This means hda8 simply isn't discovered on your system, which probably
> means hda isn't discovered.  This typically is an issue with your
> kernel configuration, but it's not always.
yes that was my problem: rc4-mm1 need CONFIG_SCSI_PATA_AMD=y
which -rc4 don't for my nForce2 ide controller.

many thankx
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux