Re: [PATCH 4/4] Streamline generic_file_* interfaces and filemap cleanups

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Badari,

On Mon, May 15, 2006 at 02:23:26PM -0700, Badari Pulavarty wrote:
> This patch cleans up generic_file_*_read/write() interfaces.
> Christoph Hellwig gave me the idea for this clean ups.
> 
> In a nutshell, all filesystems should set .aio_read/.aio_write
> methods and use do_sync_read/ do_sync_write() as their .read/.write 

I know its not something you're introducing here, but the naming
convention do_sync_read/do_sync_write is pretty confused (with it
not actually being a sync write and all, in the usual case).
Any chance that could be renamed to something thats a bit clearer,
maybe generic_file_non_aio_read and generic_file_non_aio_write?
There don't seem to be many callsites (so not a huge change) and
it'd seem a good time to do it, alongside these other changes.

> methods. This allows us to cleanup all variants of generic_file_*
> routines.
> 
> Final available interfaces:
> 
> generic_file_aio_read() - read handler
> generic_file_aio_write() - write handler
> generic_file_aio_write_nolock() - no lock write handler

thanks!

--
Nathan
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux