Jeff Dike <[email protected]> wrote:
>
> + /* 0 means don't wait (like GFP_ATOMIC) and
> + * don't dip into emergency pools (unlike
> + * GFP_ATOMIC).
> + */
> + new = kmalloc(sizeof(*new), 0);
What we've done in the past here is to use (GFP_ATOMIC & ~__GFP_HIGH). It
amounts to the same thing, but it carries some semantic meaning: "whatever
GFP_ATOMIC measn, only don't dip into page reserves".
Plus it future-safes us against changes in GFP_ATOMIC.
I'll make that change.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]