This patch set does: - Introduce hlist_add_head() and use it - Use list_add_tail() instead of list_add(A, B.prev) - Use list_move() instead of the combination of list_del() and list_add() for readability and micro optimization. -- - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [email protected] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
- Follow-Ups:
- Re: [patch 8/8] fs: use list_move()
- From: David Howells <[email protected]>
- Re: [patch 6/8] net/rxrpc: use list_move()
- From: David Howells <[email protected]>
- [patch 2/8] use hlist_move_head()
- From: Akinobu Mita <[email protected]>
- [patch 1/8] introduce hlist_move_head()
- From: Akinobu Mita <[email protected]>
- [patch 5/8] core: use list_move()
- From: Akinobu Mita <[email protected]>
- [patch 7/8] drivers: use list_move()
- From: Akinobu Mita <[email protected]>
- [patch 6/8] net/rxrpc: use list_move()
- From: Akinobu Mita <[email protected]>
- [patch 8/8] fs: use list_move()
- From: Akinobu Mita <[email protected]>
- [patch 4/8] arch: use list_move()
- From: Akinobu Mita <[email protected]>
- [patch 3/8] use list_add_tail() instead of list_add()
- From: Akinobu Mita <[email protected]>
- Re: [patch 8/8] fs: use list_move()
- Prev by Date: [patch 5/8] core: use list_move()
- Next by Date: [patch 1/8] introduce hlist_move_head()
- Previous by thread: [patch 1/1] sys_sync_file_range()
- Next by thread: [patch 3/8] use list_add_tail() instead of list_add()
- Index(es):