On Tue, 21 Mar 2006, Nathan Scott wrote:
> Sorry, but thats just silly. Did you even look at the code
> around what you're changing (it has to do more than just wrap
> up slab calls)? So, NACK on this patch - it leaves the code
> very confused (half zoney, half slaby), and is just unhelpful
> code churn at the end of the day.
You're already using kmem_cache_destroy() mixed with the zone stuff so I
don't see your point. I would really prefer to feed small bits at a time
so is there any way I can sweet-talk you into merging the patch?
On Tue, 21 Mar 2006, Nathan Scott wrote:
> For your zalloc patch, you will need to duplicate the logic
> in kmem_zone_alloc into kmem_zone_zalloc in order to use that
> new zalloc interface you're introducing - which should be fine.
I am planning to kill the slab wrappers completely. The logic you're
referring to looks awful lot like GFP_NOFAIL with limiter. Any
reason we can't just use GFP_NOFAIL for those cases?
Pekka
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]