Hugh Dickins <[email protected]> wrote:
>
> (*zap_work)--;
> continue;
> }
> +
> + (*zap_work) -= PAGE_SIZE;
Sometimes we subtract 1 from zap_work, sometimes PAGE_SIZE. It's in units
of bytes, so PAGE_SIZE is correct. Although it would make sense to
redefine it to be in units of PAGE_SIZE. What's up with that?
Even better, define it in units of "approximate number of touched
cachelines". After all, it is a sort-of-time-based thing.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]