Re: [2.6 patch] make INPUT a bool

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Feb 22, 2006 at 03:44:38AM +0100, Herbert Poetzl wrote:
> On Wed, Feb 22, 2006 at 03:31:21AM +0100, Adrian Bunk wrote:
> > On Wed, Feb 22, 2006 at 02:34:11AM +0100, Herbert Poetzl wrote:
> > > On Mon, Feb 20, 2006 at 02:28:32PM +0100, Adrian Bunk wrote:
> > > > On Mon, Feb 20, 2006 at 12:33:55PM +0900, Samuel Masham wrote:
> > > > 
> > > > > Hi Adrian,
> > > > 
> > > > Hi Samuel,
> > > > 
> > > > > > And I've already given numbers why CONFIG_EMBEDDED=y and
> > > > > > CONFIG_MODULES=y at the same time is insane.
> > > > > 
> > > > > >From your numbers this sounds true ... but actually you might want the
> > > > > modules to delay the init of the various hardware bits...
> > > > > 
> > > > > Sometime boot-time is king and you just try and get back as much of
> > > > > the size costs as it takes...
> > > > 
> > > > this is irrelevant since CONFIG_INPUT alone does not init any hardware.
> > > > 
> > > > > I think for EMBEDDED and MODULES is actually a very common case ... if
> > > > > somewhat odd.
> > > > 
> > > > You are misunderstanding EMBEDDED.
> > > 
> > > well, I suggested the following (or a similar)
> > > change some time ago (unfortunately I could not
> > > find it in the lkml archives, so it might have
> > > been lost)
> > > 
> > > http://vserver.13thfloor.at/Stuff/embedded_to_expert.txt
> > 
> > That's not a good solution since EMBEDDED is really only about 
> > additional space savings - even if you are an "expert", there's no 
> > reason to enable EMBEDDED when building a kernel for systems 
> > with > 50 MB RAM.
> 
> well, not sure everybody kows that ...
> 
>  config X86_P4_CLOCKMOD
> 	depends on EMBEDDED

This one is an x86_64 only issue, and yes, it's wrong.

>  config VT_CONSOLE
> 	bool "Support for console on virtual terminal" if EMBEDDED

Looks OK.

>  config VGA_CONSOLE
> 	bool "VGA text console" if EMBEDDED 

Looks OK.

>  config DNOTIFY
> 	bool "Dnotify support" if EMBEDDED

Looks OK.

>  config DEBUG_BUGVERBOSE
> 	bool "Verbose BUG() reporting (adds 70K)" if DEBUG_KERNEL && EMBEDDED

Looks OK.

> but, the patch was just considered a starting point
> so that folks would know _what_ EMBEDDED is currently
> used for ...

Except for the X86_P4_CLOCKMOD case, all of your examples are correct 
usages of EMBEDDED.

> > The better solution is IMHO an additional option:
> >   http://lkml.org/lkml/2006/2/7/93
> >   http://lkml.org/lkml/2006/2/7/139
> 
> whatever, just get rid of the CONFIG_EMBEDDED everybody
> get's wrong and nobody really understands ...

No, the EMBEDDED semantics shouldn't be changed and most people get it 
right.

Naming it EXPERT as you suggested would make it even worse. We could name it 
SHOW_OPTIONS_FOR_ADDITIONAL_SPACE_SAVINGS_IF_YOU_REALLY_KNOW_WHAT_YOU_ARE_DOING, 
but unless someone comes up with a name that is both short and 
significantely better than EMBEDDED I don't see a reason for changing it.

cu
Adrian

-- 

       "Is there not promise of rain?" Ling Tan asked suddenly out
        of the darkness. There had been need of rain for many days.
       "Only a promise," Lao Er said.
                                       Pearl S. Buck - Dragon Seed

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux