This is 3rd trial. I hope this patch series will be added to -mm tree.
And I would like to see what it breaks.
Changes since previous version:
- s/__inline__/inline/
- s/__const__/const/
- cleanup test_le_bit()
- hweight() speedup
- out of line hweight*()
- out of line find_*_bit()
- out of line generic_find_next_zero_le_bit()
- fix arch bitops.h for ia64 and alpha
- add hweight*() related cleanups
Boot testes on:
- i386
- ppc
Cross compiled on:
- x86_64
- ia64
- alpha
- sparc
- sparc64
Large number of boilerplate bit operations which are written in C-language
are scattered around include/asm-*/bitops.h.
This patch series gathers them into include/asm-generic/bitops/*.h .
It will be the benefit to:
- kill duplicated code and comment (about 4000 lines)
- use better C-language equivalents
- help porting new architecture
--
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
- Follow-Ups:
- [patch 08/47] generic __ffs()
- [patch 02/47] ia64: use cpu_set() instead of __set_bit()
- [patch 14/47] generic ffs()
- [patch 09/47] generic ffz()
- [patch 06/47] generic {,test_and_}{set,clear,change}_bit()
- [patch 07/47] generic __{,test_and_}{set,clear,change}_bit() and test_bit()
- [patch 01/47] alpha: use config options instead of __alpha_fix__ and __alpha_cix__
- [patch 04/47] cris: remove unnecessary local_irq_restore()
- [patch 20/47] arm: use generic bitops
- [patch 21/47] arm26: use generic bitops
- [patch 05/47] use non atomic operations for minix_*_bit() and ext2_*_bit()
- [patch 12/47] generic find_{next,first}{,_zero}_bit()
- [patch 10/47] generic fls()
- [patch 38/47] v850: use generic bitops
- [patch 35/47] sh64: use generic bitops
- [patch 33/47] s390: use generic bitops
- [patch 17/47] generic ext2_{set,clear}_bit_atomic()
- [patch 37/47] sparc64: use generic bitops
- [patch 36/47] sparc: use generic bitops
- [patch 19/47] alpha: use generic bitops
- [patch 15/47] generic hweight{64,32,16,8}()
- [patch 28/47] m68k: use generic bitops
- [patch 26/47] ia64: use generic bitops
- [patch 23/47] frv: use generic bitops
- [patch 24/47] h8300: use generic bitops
- [patch 22/47] cris: use generic bitops
- [patch 30/47] mips: use generic bitops
- [patch 25/47] i386: use generic bitops
- [patch 41/47] update include/asm-generic/bitops.h
- [patch 43/47] ia64: make partial_page.bitmap an unsigned long
- [patch 42/47] make thread_info.flags an unsigned long
- [patch 13/47] generic sched_find_first_bit()
- [patch 39/47] x86_64: use generic bitops
- [patch 29/47] m68knommu: use generic bitops
- [patch 31/47] parisc: use generic bitops
- [patch 32/47] powerpc: use generic bitops
- [patch 34/47] sh: use generic bitops
- [patch 27/47] m32r: use generic bitops
- [patch 44/47] ntfs: remove generic_ffs()
- [patch 16/47] generic ext2_{set,clear,test,find_first_zero,find_next_zero}_bit()
- [patch 18/47] generic minix_{test,set,test_and_clear,test,find_first_zero}_bit()
- [patch 11/47] generic fls64()
- [patch 40/47] xtensa: use generic bitops
- [patch 45/47] remove unused generic bitops in include/linux/bitops.h
- [patch 47/47] hweight() speedup
- [patch 46/47] hweight() related cleanup
- [patch 03/47] parisc: add ()-pair in __ffz() macro
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]