Tejun Heo wrote:
This patch kills the following request flag testing macros.
blk_noretry_request()
blk_rq_started()
blk_pm_suspend_request()
blk_pm_resume_request()
blk_sorted_rq()
blk_barrier_rq()
blk_fua_rq()
All above macros test for single request flag and not used widely and
seem to contribute more to obscurity than readability.
Signed-off-by: Tejun Heo <[email protected]>
heh, I guess that's a manner of opinion :)
To me, your patch makes things less readable. Example:
- int is_barrier = blk_fs_request(rq) && blk_barrier_rq(rq);
+ int is_barrier = blk_fs_request(rq) && rq->flags & REQ_HARDBARRIER;
After your change is applied, the above statement is no longer visually
consistent with itself. The reader must decode two different styles of
test in his brain, as opposed to one.
Jeff
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]