On 2/1/06, Nigel Cunningham <[email protected]> wrote:
> --- /dev/null
> +++ b/kernel/power/modules.h
> +struct module_header {
[snip]
> +extern int num_modules, num_writers;
[snip]
> +extern struct suspend_module_ops *active_writer;
[snip]
> +extern void prepare_console_modules(void);
> +extern void cleanup_console_modules(void);
[snip, snip]
> +extern unsigned long header_storage_for_modules(void);
> +extern unsigned long memory_for_modules(void);
> +
> +extern int print_module_debug_info(char *buffer, int buffer_size);
Suspend prefix for the names of all of the above please? They're
confusing with kernel/module.c now.
> +extern int suspend_register_module(struct suspend_module_ops *module);
> +extern void suspend_unregister_module(struct suspend_module_ops *module);
> +
> +extern int suspend2_initialise_modules(int starting_cycle);
> +extern void suspend2_cleanup_modules(int finishing_cycle);
> +
> +int suspend2_get_modules(void);
> +void suspend2_put_modules(void);
I think we can call these suspend_{get|set}_modules instead i.e.
without the extra '2'.
> +
> +static inline void suspend_initialise_module_lists(void) {
> + INIT_LIST_HEAD(&suspend_filters);
> + INIT_LIST_HEAD(&suspend_writers);
> + INIT_LIST_HEAD(&suspend_modules);
> +}
I couldn't find a user for this. I would imagine there's only one,
though, and this should be inlined there?
Pekka
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]