This patch looks broken. I see the lines:
+ .remove = cx_device_remove,
- cx_driver->driver.remove = cx_driver_remove;
The routine (not in this patch) is still known as "cx_driver_remove"
but now it is linked to from the .remove line as "cx_device_remove"
A defconfig ia64 build of *-mm3 with this patch fails:
arch/ia64/sn/kernel/tiocx.c:151: error: `cx_device_remove' undeclared here (not in a function)
arch/ia64/sn/kernel/tiocx.c:151: error: initializer element is not constant
arch/ia64/sn/kernel/tiocx.c:151: error: (near initialization for `tiocx_bus_type.remove')
arch/ia64/sn/kernel/tiocx.c:137: warning: `cx_driver_remove' defined but not used
When I s/cx_device_remove/cx_driver_remove/, then ia64 *-mm3 defconfig builds fine.
--
I won't rest till it's the best ...
Programmer, Linux Scalability
Paul Jackson <[email protected]> 1.925.600.0401
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Stuff]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
[Linux Resources]