Re: [PATCH 1/3] mm: rename kmem_cache_s to kmem_cache

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Pekka Enberg <[email protected]> wrote:
>
> This patch renames struct kmem_cache_s to kmem_cache so we can start using it
>  instead of kmem_cache_t typedef.

Well I stared at these diffs for a long time.  They don't really add a lot
of value to the kernel and they do risk breaking other people's patches. 
Generally they have a high hassle/value ratio.

I could merge them up and see how it goes, but given that there are many
more kmem_cache_t->struct kmem_cache conversions to go, and that I hit
seven rejects in mm/slab.c, I think I'll duck the patches, sorry.


> -void filp_ctor(void * objp, struct kmem_cache_s *cachep, unsigned long cflags)
> +void filp_ctor(void * objp, struct kmem_cache *cachep, unsigned long cflags)

See the inconsistent coding style there?  This would have been a zero-cost
opportunity to fix that up.  (Nuke the space after the asterisk).
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux