[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On Sun, 2005-09-25 at 00:56 +0100, Dave Airlie wrote:
> >
> > drivers/char/drm/drmP.h defines a macro DRM_ARRAY_SIZE(x) for
> > determining the size of an array. kernel.h already provides one.
> >
> > Signed-off-by: Alexey Dobriyan <[email protected]>
> Nak.
> We have DRM_ for cross platform reasons in DRM, I could in theory get rid
> of all of them in the kernel, but it would make the merging of code from
> DRM CVS even more of a nightmare,

ok so this brings the question: how does naming it DRM_ARRAY_SIZE make
it more portable than naming it ARRAY_SIZE?
If *BSD doesn't have ARRAY_SIZE, then surely naming it ARRAY_SIZE is
easy for them to provide (after all they need to provide it already just
called DRM_ARRAY_SIZE); if they have ARRAY_SIZE... then I assume it has
the exact same semantics....

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at
Please read the FAQ at

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]
  Powered by Linux