Re: I request inclusion of reiser4 in the mainline kernel

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



more trivial review comments ontop of the previous one, after looking
at things:

 - please never use list_for_each in new code but list_for_each_entry
 - never use kernel_thread in new code but kthread_*
 - do_sendfile duplicates the common sendfile code.  why aren't you
   using the generic code?
 - there's tons of really useless assertation of the category
   discussed in the last thread
 - there's tons of deep pagecache messing in there.  normally this
   shouldn't be a filesystem, and if this breaks because of VM changes you'll
   have to fix it, don't complain..
 - you still do your plugin mess in ->readpage.  honsetly could you
   please explain why mpage_readpage{,s} don't work for you?
 - (issues with the read/write path already addresses in the previous thread)
 - looking at ->d_count in ->release is wrong
 - still has security plugin stuff that duplicates LSM
 - why do underlying attributes change when VFS inode doesn't change?
   if not please rip out most of getattr_common
 - link_common S_ISDIR doesn't make sense, VFS takes care of it
 - please use the generic_readlink infrastructure

additinoal comment is that the code is very messy, very different
from normal kernel style, full of indirections and thus hard to read.
real review will take some time.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]
  Powered by Linux