On Tue, Aug 23, 2005 at 10:26:53PM +0200, Miklos Szeredi wrote:
Bad names, IMO.
> +static inline void dput_path(struct path *path, struct nameidata *nd)
> +{
> + dput(path->dentry);
> + if (path->mnt != nd->mnt)
> + mntput(path->mnt);
> +}
> +
> +static inline void path_to_nameidata(struct path *path, struct nameidata *nd)
> +{
> + dput(nd->dentry);
> + if (nd->mnt != path->mnt)
> + mntput(nd->mnt);
> + nd->mnt = path->mnt;
> + nd->dentry = path->dentry;
> +}
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
[Index of Archives]
[Kernel Newbies]
[Netfilter]
[Bugtraq]
[Photo]
[Gimp]
[Yosemite News]
[MIPS Linux]
[ARM Linux]
[Linux Security]
[Linux RAID]
[Video 4 Linux]
[Linux for the blind]
|
|