Re: [-mm patch] make kcalloc() a static inline

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, 15 Aug 2005, Denis Vlasenko wrote:
> Sure, I don't want to disable the check. I want that check to be
> in _non-inlined function_.
> 
> static inline void *kcalloc(size_t n, size_t size, unsigned int __nocast flags)
> {
> 	if (__builtin_constant_p(n)) {
> 		if (n != 0 && size > INT_MAX / n)
> 			return NULL;
> 		return kzalloc(n * size, flags);
> 	}
> 	return kcalloc_helper(n, size, flags);
> }
> 
> void *kcalloc_helper(size_t n, size_t size, unsigned int __nocast flags)
> {
> 	if (n != 0 && size > INT_MAX / n)
> 		return NULL;
> 	return kzalloc(n * size, flags);
> }

That's extra complexity and code duplication. How much do we shave off 
kernel text of allyesconfig with this?

Please note that whenever the caller does proper bounds checking, GCC can 
optimize the security check away. Therefore, in practice, we don't spread 
around the extra operations so much, I think.

			Pekka
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]
  Powered by Linux