Re: [PATCH 3/6][XEN][x86] Rename usermode macro

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Vincent Hanquez <[email protected]> wrote:
>
> The following patch rename user_mode to user_mode_vm and add a user_mode macro
>  similar to the x86-64 one.

Why didn't your testing pick up the x86_64 build error?

arch/x86_64/oprofile/built-in.o(.text+0x1d09): In function `x86_backtrace':
arch/x86_64/oprofile/../../i386/oprofile/backtrace.c:94: undefined reference to `user_mode_vm'


Signed-off-by: Andrew Morton <[email protected]>
---

 include/asm-x86_64/ptrace.h |    1 +
 1 files changed, 1 insertion(+)

diff -puN include/asm-x86_64/ptrace.h~xen-x86-rename-usermode-macro-fix include/asm-x86_64/ptrace.h
--- 25/include/asm-x86_64/ptrace.h~xen-x86-rename-usermode-macro-fix	2005-04-27 18:22:12.000000000 -0700
+++ 25-akpm/include/asm-x86_64/ptrace.h	2005-04-27 18:22:12.000000000 -0700
@@ -82,6 +82,7 @@ struct pt_regs {
 
 #if defined(__KERNEL__) && !defined(__ASSEMBLY__) 
 #define user_mode(regs) (!!((regs)->cs & 3))
+#define user_mode_vm(regs) user_mode(regs)
 #define instruction_pointer(regs) ((regs)->rip)
 extern unsigned long profile_pc(struct pt_regs *regs);
 void signal_fault(struct pt_regs *regs, void __user *frame, char *where);
_

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux