[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 10/03/2010 04:25 PM, Jim wrote:
>    On 10/03/2010 02:31 PM, JD wrote:
>> On 10/03/2010 08:15 AM, Jim wrote:
>>>        From the Client to Server ssh [email protected] and the Client timed
>>> out and nothing has shown up on Server debug.
>>>
>>> I can ssh to any of my laptops on my local lan but not across the internet.
>>>
>>> if I knew that when I went from FC12 to 13 I would have stayed with F12.
>>> oh Well FC14 comes out in another month, i hope I have better luck.
>>>
>>> Below is all i get on the debug below, it just sits there listening .
>>>
>>> # service sshd restart
>>> Stopping sshd:                                             [FAILED]
>>> Starting sshd: debug1: sshd version OpenSSH_5.4p1
>>> debug1: read PEM private key done: type RSA
>>> debug1: private host key: #0 type 1 RSA
>>> debug1: read PEM private key done: type DSA
>>> debug1: private host key: #1 type 2 DSA
>>> debug1: rexec_argv[0]='/usr/sbin/sshd'
>>> debug1: rexec_argv[1]='-d'
>>> Set /proc/self/oom_adj from 0 to -17
>>> debug1: Bind to port 22 on 0.0.0.0.
>>> Server listening on 0.0.0.0 port 22.
>>> debug1: Bind to port 22 on ::.
>>> Server listening on :: port 22.
>> Jim, I do not think the problem in your client machine's F13.
>> So please do not assume F13 is the culprit.
>> The "block" is somewhere between your gateway and the remote server.
>> That's you should be investigating.
>>
>> As a test, can someone on the remote server ssh to your
>> F13 client?
>>
>>
> I tried that today from my sister's Fedora 12 computer to mine, Fedora
> 13, and I get the same error;    ssh: connect to host 69.58.52.206 port
> 22: Connection timed out.
>
> She is setting behind a Linksys router and i'am not.
>
> What about changing the Port 22 to something else ?
What about her linksys router? does IT allow port 22 traffic
in and out?

And your machine? Is IT on a router? If yes, have you check
the router to see if it has a firewall that does not allow port 22
traffic?
I am really suspecting only firewall issues, and not F13 issues.
Changing the port number on which your sshd daemon listens
could work if some firewall is blocking port 22 traffic.
You change the sshd port number by editing

In /etc/ssh/sshd_config you will see lines like:

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented.  Uncommented options change a
# default value.

#Port 22
#AddressFamily any
#ListenAddress 0.0.0.0
#ListenAddress ::

Uncomment Port 22
and change it 22 to say ... 2222

and restart your sshd.

On your sister's machine, ssh to your machine like so:

ssh 69.58.52.206 -p 2222

and let us know if that worked.

If it does work, then your problem is indeed a firewall setting.

Good luck.

JD
-- 
users mailing list
[email protected]
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]
  Powered by Linux