Re: Problems with network install on Fedora 11

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Jun 30, 2009 at 8:06 AM, Bruno
Rebeschini<[email protected]> wrote:
> Hi,
>
I managed to get an http install to work, although it was a headache.

What I used to boot with was a cd on which I had burned:
Fedora-11-i386-netinst.iso

That iso was not on the DVD image, I found it on one of the mirrors
where the CD images were, just looked for it again, and found it here:
ftp://ftp.ua.kernel.org/pub/mirrors/fedora/releases/11/Fedora/i386/iso/

Not absolutely sure you need to use this image, but I tried it after
nothing else had worked, and it got me one step closer.

> ...I referred to method=http://... with:
>  - the DVD mounted on my desktop and made available with Apache
>  - content of the DVD copied on my desktop and made available with Apache
>  - a mirror available on the net
>

Here are some of things I resorted to to get the install to work, I
cannot confirm that all of these were absolutely necessary, but it
worked for me.

Giving the server name after http:// did not work, when I used the ip
address instead it worked.

I also had problems when I attempted to use DHCP, so I wound up
configuring the network stuff manually, supplying the ip address,
netmask, gateway and nameserver.

Although I've heard it is not necessary to mount the DVD iso image, in
my case I did mount the image.  Then I made a link to the mounted
image in the apache tree:

ln -s /mnt/dvd_image /var/www/html/fedora

then when I supplied http://123.243.234.1/fedora (with the actual ip
address) the installer at least found the files on the DVD image.

There were some other problems that I encountered after that which
involved the configuration of apache.  The machine I used to serve the
DVD iso files is a live server, accessible on the internet, and there
were a number of hacks required to loosen the security to get the
install to proceed.  If you are starting with a plain vanilla apache
install this may not be an issue for you.  Let me know if you get to
this point and have problems and I'll post more details.

In any case, you should watch the apache logs on the machine serving
the files while trying to install: tail -f /var/log/httpd/error_log
and tail -f /var/log/httpd/access_log in two terminal windows will let
you know if the installer is actually trying to get stuff from the
server and what happened.

One oddity I encountered occurred after the first time the installer
tried to access the server and got an error which required a change to
the apache config.  I changed the apache config, restarted apache,
then retried the install.  There was no attempt to access the server,
just an error reported by the installer.

At that point I took a guess that the initial install failure had
written something on the disk that was causing it to not try to access
the web server and rebooted the target machine with the CD and this
time reformatted the disk.  After that the install started to work.

I ran into some other problems related to security on the web server
and had to make some more changes to the apache config.

Interestingly, once the installer started fetching files, when it ran
into errors I was able to make changes to the apache config, restart
apache, then the retry button worked, the installer actually did a
retry and I managed to get everything installed.

Hope this helps, let me know if you need help with apache problems, I
have notes about what I changed on the server end to get the install
to complete.

Cheers,

Mike


> ...every time, the download starts and retrieves the install.img image on
> the network and then shows the error message "Unable to retrieve the install
> image".

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux