Nagios can't connect to Pulseaudio via Festival

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This is a Fedora10 installation.  Everything worked fine in my Ferdora9
installation.

Here are some facts.
1) Logged in as a normal user, xmms player works.
2) Logged in as a normal user I can send text to festival with correct
speech.
3) As root, cron job works (I have the time being said via festival).
4) As root, via commandline, I get this error;
	Connection failure: Connection refused
5) Log file shows this when nagios has an error to report.

Jan 22 08:33:37 localhost pulseaudio[7413]: alsa-util.c: Error opening PCM device hw:0: Permission denied
Jan 22 08:33:37 localhost pulseaudio[7413]: module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_1274_1371_sound_card_0_alsa_playback_0 tsched=1"): initialization failed.
Jan 22 08:33:37 localhost pulseaudio[7413]: alsa-util.c: Error opening PCM device hw:0: Permission denied
Jan 22 08:33:37 localhost pulseaudio[7413]: module.c: Failed to load  module "module-alsa-source" (argument: "device_id=0 source_name=alsa_input.pci_1274_1371_sound_card_0_alsa_capture_0 tsched=1"): initialization failed.
Jan 22 08:35:54 localhost pulseaudio[7539]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 44099 Hz.
Jan 22 08:36:20 localhost pulseaudio[7622]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 44099 Hz.
Jan 22 08:36:35 localhost pulseaudio[7667]: alsa-util.c: Error opening PCM device hw:0: Permission denied
Jan 22 08:36:35 localhost pulseaudio[7667]: module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_1274_1371_sound_card_0_alsa_playback_0 tsched=1"): initialization failed.
Jan 22 08:36:35 localhost pulseaudio[7667]: alsa-util.c: Error opening PCM device hw:0: Permission denied
Jan 22 08:36:35 localhost pulseaudio[7667]: module.c: Failed to load  module "module-alsa-source" (argument: "device_id=0 source_name=alsa_input.pci_1274_1371_sound_card_0_alsa_capture_0 tsched=1"): initialization failed.
Jan 22 08:38:55 localhost pulseaudio[7734]: alsa-util.c: Error opening PCM device hw:0: Permission denied
Jan 22 08:38:55 localhost pulseaudio[7734]: module.c: Failed to load  module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_1274_1371_sound_card_0_alsa_playback_0 tsched=1"): initialization failed.
Jan 22 08:38:55 localhost pulseaudio[7734]: alsa-util.c: Error opening PCM device hw:0: Permission denied
Jan 22 08:38:55 localhost pulseaudio[7734]: module.c: Failed to load  module "module-alsa-source" (argument: "device_id=0 source_name=alsa_input.pci_1274_1371_sound_card_0_alsa_capture_0 tsched=1"): initialization failed.


I have added user nagios to these groups.

pulse, pulse-rt, pulse-access

Googling I found this,

http://www.pulseaudio.org/ticket/426

but there does not seem to be solution posted.

This command returns nothing.
fuser -v /dev/snd/* /dev/dsp*

I start in runlevel 3, so no Gnome or xwindow processes start.
I have done nothing to modify original configuration of pulseaudio.

Any ideas?

Durwin

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux