[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sun, 2008-07-06 at 18:08 -0700, bruce wrote:
> Hi...
> 
> Weird issue here, that I can't recall how I solved it before. Googled sites
> aren't shedding any light either.
> 
> I've got a dell optiplex 320 from an auction...I'm looking to install fedora
> 8/9 on the box. I've performed the initial installation, where I created the
> raw partition, and installed the basic fedora OS.
> 
> I reformatted the drive to be:
>  /		primary partition (ext3)
>  /boot		100M (ext3)
>  /swap		4G (swap)
> 
> /etc/fstab
> LABEL=/		/		ext3	defaults	1 1
> LABEL=/boot		/boot		ext3	defaults	1 2
> tmpfs			/dev/shm	tmpfs	defaults	0 0
> devpts			/dev/pts		devpts	gid=5,mode=620	0 0
> sysfs			/sys		sysfs	defaults	0 0
> proc			/proc		procs	defaults	0 0
> LABEL=SWAP-sda3/	swap		swap	defaults	0 0
> 
> 
> e2label /dev/sda1
>  /boot
> 
> e2label /dev/sda2
>  /
> 
> 
> i manually configured the partitions for the drive and got the results
> above.
> 
> in order to install/boot fedora, you need to use lilo, instead of grub.
> 
> so i downloaded/installed lilo, along with the config file for lilo
> 
> lilo.conf:
> ----------------------------------------------------------------
> boot=/dev/sda
> map=/boot/System.map-2.6.23.1-42.fc8
> prompt
> timeout=50
> lba32
> default=linux
> 
> image=/boot/vmlinuz-2.6.23.1-42.fc8
> label=linux
> append="acpi=off pci=nomsi root=LABEL=/"
> initrd=/boot/initrd-2.6.23.1-42.fc8.img
> read-only
> -------------------------------------------------------------------
> 
> 
> the dir for "/mnt/sysimage/boot" is:
> System.map-2.6.23.1-42.fc8
> config-2.6.23.1-42.fc8
> grub
> initrd-2.6.23.1-42.fc8.img
> lost+found
> vmlinuz-2.6.23.1-42.fc8
> 
> when i do an lilo -v"
> 
> i get the following err msg:
> ----------------------------------------------------------
> Reading boot sector from /dev/sda
> Fatal: Trying to map files from unnamed device 0x0001 (NFS/RAID mirror down
> ?)
> 
> so... i'm missing something and i can't see it!!!
> 
> any thoughts/comments would be greatly appreciated...
----
chroot /mnt/sysimage # you must do this first
lilo -v # lilo should be installed in /sbin # /mnt/sysimage/sbin before
you chroot

Craig

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]
  Powered by Linux