Re: Dependency resolution failed

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sun, Jun 29, 2008 at 18:31:35 -0700,
  stan <[email protected]> wrote:
> Luis Orlindo Tedeschi wrote:
>> Folks; I've been trying to update Fedora 9 since last week and I keep
>> getting Dependency Resolution Failed. It says Missing Dependency:
>> tcl-devel = 1:8.5.1 is needed by package 1:tk-devel: 8.5.1-4.fc9.i386.
>> Does anyone have a solution for this? Thanks in advance.
>>
>>   
> It is trivial to do the following.  (as root)
> yum list updates > updates
> Edit updates to leave only the packages.  Put #! /bin/bash at the top.   

You don't need to do that any more. Yum will skip the broken packages.
(I don't think skip_broken is the default, so you probably want to add
that option to /etc/yum.conf .)

> When I was using rawhide I automated this with scripts and python  
> programs (well, more sophisticated than this).  There are almost always  
> dependency errors in rawhide, so you would never get any updates if you  
> didn't do something like this.

Things should be much better now. (THe change happened during the F9 rawhide
period.) Only some file conflicts which are detected after the packages to
be updated are selected, cause all updates to fail.

-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux