[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi.

I had Fedora 7 installed on my computer and the sound works fine (I was quite happy to be able to hear several sounds at the same time : pidgin, totem and the flash plugin for example).

I installed F8 (no update, I did a full reinstall) and now sometimes I got some sound but sometimes not, that's quite strange.
I'm quite surprised because one of the main features of F8 was PulseAudio which was supposed fix all the sound's problems.

Is there a page telling how PulseAudio is supposed to work on F8 ? (when is it launched ? by whom ? ...)

I did a system-config-soundcard and was able to hear the sample sound.
Then I tried to to play a wav through aplay but I have this message :
# aplay /usr/share/sounds/phone.wav
*** PULSEAUDIO: Unable to connect: Connection refused
aplay: main:546: audio open error: Connection refused

If I try to play the wav file as root with totem it works, but if I try to still play with totem as a normal user it doesn't and I get this error message :
$ totem /usr/share/sounds/phone.wav
JACK tmpdir identified as [/dev/shm]
*** PULSEAUDIO: Unable to connect: Connection refused

Then I tried as root to launch manually pulseaudio. Here is the output :
# pulseaudio --system=true
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-sink.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:0 sink_name=alsa_output.pci_8086_266e_alsa_playback_0"): initialization failed.
ALSA lib pcm_hw.c:1207:(_snd_pcm_hw_open) Invalid value for card
E: module-alsa-source.c: Error opening PCM device hw:0: No such device
E: module.c: Failed to load  module "module-alsa-source" (argument: "device=hw:0 source_name=alsa_input.pci_8086_266e_alsa_capture_0"): initialization failed.
No protocol specified
E: x11wrap.c: XOpenDisplay() failed
E: module.c: Failed to load  module "module-x11-publish" (argument: ""): initialization failed.
E: main.c: Module load failed.
E: main.c: failed to initialize daemon.

Can someone help me to make pulseaudio working ?

Some information that may be useful :
# rpm -qa | grep flash
libflashsupport-000-0.1.svn20070904
flash-plugin-9.0.64.0-release
# rpm -qa | grep alsa
alsa-lib-devel-1.0.15-1.fc8
alsa-plugins-pulseaudio-1.0.14-5.fc8
alsa-utils-1.0.15-1.fc8
alsa-lib-1.0.15-1.fc8
bluez-utils-alsa-3.20-4.fc8


Regards,
Laurent


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]
  Powered by Linux