[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



sorry that I cant keep the thread when replying
because I am reading this list via mail-archive.


>Konrad Karl wrote:
>> Hi list,
>> 
>> after a fresh FC5 install (mostly everything) and applying all
>> updates I seem to be unable to use Luxi Mono in the KDE
>> konsole - it is simply not being offered as a choice.
>
>It happens to me too.

I am glad that I am not the only one :-)

>
>> Googling around did not show anything substantial, the only
>> meaningful info I got was something about qt believing that
>> one of the four files of the Luxi Mono font family (normal,bold, etc) was
>> not considered as fixed width.
>
>Exactly. The best info I was able to find is this:
>  http://lists.kde.org/?l=kde&m=110617132115635&w=2
>
>> In the KDE control center font installation 
>> all the Luxi fonts are listed as postscript type 1, however
>> they are installed as TTF as well:

I have tried uninstalling xorg-x11-fonts-Type1-7.0-3 but this
did not help in contrast to your above URL.

"did not help" means: did not help in KDE konsole. Gnome terminal
was able to use the TTF equivalent but it looked rather ugly
(badly hinted or antialised).

>> 
>> xorg-x11-fonts-truetype-7.0-3  /usr/share/X11/fonts/TTF/luximb.ttf etc.
>> and
>> xorg-x11-fonts-Type1-7.0-3     /usr/share/X11/fonts/Type1/l047013t.pfa etc.
>
>Apparently deleting the type1 font solves the problem, because the TTF
>is seen as monospaced.
>I haven't tried yet.
>
>> at home I am using a machine which has been updated from FC4 (and FC3)
>> and did not yet receive the latest FC5 KDE updates. 
>> On this machine Luxi Mono shows up on the konsole font 
>> selection dialog just fine.
>
>Probably something changed in QT.

I will make a backup on my home machine and then apply all the latest
updates and see what I will get.

>
>> Really annoying....
>> 
>> Any hints ane ideas highly welcome.
>
>Avoiding the Type1 could be a solution.
>
>I had a look into the type1 files
>
>  /usr/share/X11/fonts/Type1/l047016t.afm
>
>and
>
>  /usr/share/X11/fonts/Type1/l047036t.afm
>
>and I saw that some letters have widths=653 instead
>of 600.

This may indeed be the real reason for this mess.

What tool did you use to see the letter widths?

>
>Maybe this is the reason that invalidates the "monospace"
>attribute.

I think so as well.

Greetings,

Konrad

>
>Best regards.
>-- 
>   Roberto Ragusa    mail at robertoragusa.it


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]
  Powered by Linux