Re: Kernel 2.6.16 Problems FC4 and FC5

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, 2006-06-06 at 23:16 +0000, S.W. Bobcat wrote:
> I qam posting this in hopes that some developer might see this. I agree with 
> the idea that we need a time out to fix bugs.
> 
> First a note on my system ( as this data may be needed ): CPU: Opteron 144;  
> Mobo:  ASUS, SK8V; RAM: 512 MB Reg ECC; Video Card: Nvidia 6600 GT w/ 128 MB 
> DDR3 VRAM;  120 GiB Maxtor SATA Harddrive; DVD RW; CD RW; CD Read Only; Zip 
> Drive; 3.5 " Floppy Drive; OS (for the time being, Fedora Core 4 
> w/2.6.15-1.1833 x86_64 Kernel.
> 
I've been running FC5 2.6.16-1.2122_FC5 on my Dual Opteron ASUS K8N-DL
with 6GB Ram and a Nvidia 6200 PCI-E card without much in the way of
issues...maybe I'm just lucky?  :)

> PROBLEM #1: Like Many people I was looking forward to the release of FC5. 
> When the chance came I was an early adopter. When I installed FC5 I was 
> greeted with a message to the effect that my Home directory setup would not 
> be saved and that I needed to make sure that my home directory was set to 
> 644 (or maybe 664 -- can't remember ) permissions. After hacking away with a 
> buddy of mine we figured out how to set it. Regular attempts using chmod did 
> not work [ I think we had to do it from root @~ then had to use chmod -R 644 
> /home/rhr ].
> 
Perchance was this an upgrade of FC4?

> Problem #2: Once I had that problem solved. I tried to start up Star Office 
> 6.0, located in my home directory as well as set up in /usr/local/office60. 
> Regardless of what I tried Star Office 6.0 would not start or could it be 
> installed. Additionally I had problems with Open Office 2.0 ( which crashed 
> with regularity, sometimes taking the whole system with it. Which explaines 
> why I use Star Office 6.0). I also had troubles with VMware's VMplayer 
> (Could not get it to work.), as well as NVIDIA drivers ( Could not get it to 
> work ). I gave up on of FC5 and did a restore of my FC4 w/kernel 
> 2.6.15-1.1833.
> 
Been running the NVIDIA drivers from livna.org since the release came
out.  Not sure what the problems you had were, but there were some
issues with the NVIDIA installer that the fine folks at livna had
'worked around' in their packages.

> Problem #3: After a few weeks when I was sure things had been "fixed" in 
> FC5, I did another re-install of FC5. This time I had all the same problems 
> as above but this time Open Office would not even start let alone start then 
> crash. Once again I did a total restore of FC4 w kernel 2.6.15-1.1833.
> 
> Problem #4: One week later I was sure the the problem was that some of my 
> links were being broken when I tried to "install" FC5. To avoid this problem 
> I decided to an "update" to FC5 in hopes that all my links would remain and 
> that I could circumvent the problems associated with a FC5 installtion. The 
> answer: I had all the same problems as with the regular install but not i 
> got a message that mc [Midnight Commander] would not start due to problems 
> with shared libaries. Once again, I did a restore of FC4 w kernel 
> 2.6.15-1.1833. I reached the conclusion that FC5 is UNSTABLE.
> 
I almost sounds like you are installing on a second disk or something.
When you reference 'links' it seems that the applications, like
StarOffice, exist prior to the install.  Is this the case?

> Problem #5: Once I gave up on FC5 I decided to upgrade FC4. I downloadedall 
> the updates since April 20th, and ran yum -y update. That included the 
> latest and greatest kernels of 2.6.16-1.2069 [3/29/06]. and -1.2096 
> [4/20/06] For reasons unknown after my last update niether kernal got 
> installed but both are listed in my updates. After 4/20/06 we have 
> 2.6.16-1.2107 [5/306], -1.2108 [5/5/06], and -1.2111 [5/21/06] . Everything 
> went smoothly. I then went to edit a .html file and I could not; I then 
> tried to do something with Star Office 6.0. Which was not respondind, so I 
> killed it and then tried to restart the program but I could not, ala FC5. I 
> did a complete restore (again)  of FC4 w/ kernel 2.6.15-1.1833, and once 
> again everything was fine. By this time I started to think that there is 
> something very, very wrong with something, and that something had to with 
> something in the updates which are common to both FC4 and FC5. I then did a 
> search to see what was new in the updates in FC4, which might be causing me 
> such grief. I found that, since my previous update that there were two 
> possible sources for my problems: xorg-x11 was updated on 5/2.06; and the 
> kernels -1.2107 [5/3/06], -1.2108 [5/5/06], and -1.2111 [5/21/06].
> 
> My buddy reported that when in installed kernel 2.6.16-1.2069 (x86_64) some 
> of his important apps stop working including NVIDIA, and VMware. To avoid 
> any possible risks that might be found, in the .2069 kernel, I installed  
> [rpm -ivh... .rpm] the -1.2096 kernel. This way I could avoid the update 
> problem that might be associated with kernels .2107, .2108, and .2111 which 
> were after the release of the xorg-x11 updates but preceeded the 
> xorg-x11updates.

I've discovered that I needed to install xorg-x11-server-sdk in order to
get the Nvidia drivers to work properly, if installed from the Nvidia
installer.  I had to play some games with TransGaming's software to
figure this out.  But, none-the-less, I use the Livna RPM's without any
issues.

> After I did the install of the 2.6.16-1.2096 x86_64 kernal (remember I have 
> an Opteron system, and run everything if I can in x86_64  mode) I then shut 
> down and rebooted the new kernel. Once up I tried to run Star Office 6.0 and 
> I could not get it run  or install. I then shut down and rebooted my system 
> with the 2.5.15-1.1833 x86_64 kernel and once up tried to start Star Office 
> 6.0  and it started up just fine.
It  would be interesting if you could run 'soffice.bin' or whatever the
Star Office executable is from a shell and post the output.  It might
lead you to what changed.
> 
> CONCLUSION: There is something very, very messed up with the 2.6.16 series 
> of kernels. Star Office 6.0 has been very easy to install and start up till 
> 2.6.16; that other apps including NVIDIA, and VMware  are also affected ( as 
> well as some more specific apps I do not use but my buddy does), suggests 
> that something was changed within the 2.6.16 kernal which broke a lot of 
> links, which has lead to problems with various apps that predate the 2.6.16 
> series. Given that it has been suggested that we take a time out to fix 
> bugs, this is one kernal bug that needs to be fixed -- that or a suggestion 
> on a workaround should be posted.
> 
> The question now becomes is this a problem ONLY with the 2.6.16... x86_64 
> series of kernals or does this problem affect ALL 2.6.16 kernals ( 32 and 64 
> bit ).

I haven't seen the exact issues that you are referencing, but there is
some lag from the commerical vendors right now ... You may want to ask
VMWare why the latest kernel causes issues.

I hope this was of some use to you.

Sean


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]
  Powered by Linux