Re: Setting up a tftp-server in fedora?

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



I'll show you how I found out, it's a useful method (not rocket science, I'm 
rubbish with this kind of thing), then you'll be able to figure out if it's 
running or not.

I used:
yum -y install tftp-server

When that had installed I tried
man tftp-server

Nothing. So I used:

man tftpd

More logical (I should have tried it first), that brought up a manual page. 
I closed that (would have read it but you mentioned it was in /etc/xinetd.d 
so I didn't bother). I went in and enabled it in /etc/xinetd.d/tftp. Then I 
restarted xinetd:
service xinetd restart

Then I did:
nmap -sS 127.0.0.1
Which was stupid as in the tftp file in xinetd.d it said it was udp, so 
nothing showed up. So I gave it

nmap -sU 127.0.0.1

This showed tftpd on port 69. I have a tftp server running. Maybe it's a bit 
long winded, but it works for me! :D

I usually run NMap after installing / upgrading a server application, just 
to see if it's there or not, it's quicker than using telnet, as, on a 
windows box, telnet takes ages to figure out if it'll connect or not.

HTH,

Chris.
From: "Jonathan Carpenter" <[email protected]>
To: "Fedora-Redhat-List" <[email protected]>
Sent: Thursday, March 02, 2006 3:54 PM
Subject: Setting up a tftp-server in fedora?


I am wanting to setup a tftp-server in fedora 4, so that I can send my
configs and firmware from my cisco equitment to it. I have installed the
tftp-server using yum can found the config file in /etc/xinetd.d/tftp, I
change it from disable = yes to disable = no. but I am not sure how to start
things from xinetd. I chown +x tftp and ran ./tftp and it seemed to have
changed the status in chkconfig to on. But I am still a bit lost. I am
making this to hard?

                     Thanks,

--
Jonathan Carpenter



--------------------------------------------------------------------------------


-- 
fedora-list mailing list
[email protected]
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list 


[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]

  Powered by Linux