Re: Problem with spamassassin/sendmail

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



A quick google shows this link which tends to indicate it may be a permissions issue
<http://lists.gnu.org/archive/html/spamass-milt-list/2003-04/msg00028.html>


John


Timothy Murphy wrote:
<posted & mailed>

Craig White wrote:


spamassassin seems to have stopped performing on my desktop.
I am getting the following 2-line message in /var/log/maillog :
===============================================================
Oct 16 03:25:10 alfred sendmail[7341]: j9G2PAGa007341:
       Milter (spamassassin):
       local socket name /var/run/spamass.sock unsafe
Oct 16 03:25:10 alfred sendmail[7341]: j9G2PAGa007341:
       Milter (spamassassin):
       to error state
===============================================================
...

I'm running Fedora-4, with spamassassin-3.0.4-1.fc4
and spamass-milter-0.3.0-8.fc4 ,

Any and all suggestions gratefully received.
----
service spamass-milter restart

Thanks for the response, and for the suggestion.

I had tried this before, but I tried it again.
(I also restarted spamassassin and sendmail.)
However, I am still getting the message above repeatedly
in /var/log/maillog .
It is repeated every 10 minutes, which is the period
at which I collect email,
admittedly by the rather odd method of uucp (uucico),
but I don't think that should be a problem.

The message comes from sendmail,
and seems to suggest that sendmail does not like to open a socket
with local name /var/run/spamass.sock .

What does it mean to say that this is "unsafe"?

I notice that spamass-milter seems to have no problem
with /var/run/spamass-milter/spamass-milter.sock .

If anyone can throw enlightenment on this,
I shall be very grateful.







[Index of Archives]     [Current Fedora Users]     [Fedora Desktop]     [Fedora SELinux]     [Yosemite News]     [Yosemite Photos]     [KDE Users]     [Fedora Tools]     [Fedora Docs]
  Powered by Linux