Re: [-mm patch 1/4] GPIO framework for AVR32

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, 7 Nov 2006 12:27:15 +0100
Haavard Skinnemoen <[email protected]> wrote:

> Add a simple GPIO framework for AVR32. This should be fairly similar
> to the AT91 GPIO API, but there are still a couple of differences:
> 
>   * Naming. We prefix all functions with gpio_ instead of at91_
>   * request_gpio() and free_gpio() should be called to make sure
>     the required pins are available, but it will still work if you
>     don't.

+EXPORT_SYMBOL(request_gpio);
+EXPORT_SYMBOL(free_gpio);
+EXPORT_SYMBOL(gpio_set_value);
+EXPORT_SYMBOL(gpio_get_value);
+EXPORT_SYMBOL(gpio_set_output_enable);
+EXPORT_SYMBOL(gpio_set_pullup_enable);

I wonder about this naming choice.  I'd have though that if/when the kernel
gets a generic GPIO driver or layer, these avr32-specific symbols will need
renaming.

h8300 uses h8300_free_gpio(), and there's also omap_free_gpio().  Perhaps
this patch should have added avr32_free_gpio()?

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux