Re: 2.6.17-rc6-mm2

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 6/15/06, Goo GGooo <[email protected]> wrote:
Andrew Morton wrote:

> - To fetch an -mm tree using git, use (for example)
>
>  git fetch git://git.kernel.org/pub/scm/linux/kernel/git/smurf/linux-trees.git
> v2.6.16-rc2-mm1

I'm not able to get -mm tree from GIT. In
http://git.kernel.org/.../smurf/linux-trees.git/refs/tags/ I can see
the most recent tags like v2.6.17-rc6-mm2 but cg-clone
http://git.kernel.org/.../smurf/linux-trees.git gives me only
2.6.16-rc3 :(

I tried "cg-fetch v2.6.17-rc6-mm2" which seemed to fetch some more
tags, then played with git-checkout & friends but still can't get the
most recent source tree.
All right, finally this worked out:
git pull rsync://git.kernel.org/pub/scm/linux/kernel/git/smurf/linux-trees.git \
     tag v2.6.17-rc6-mm2

Strange enough with http:// instead of rsync:// I got some message
about nonexistent tag.

Now when I try git pull with http:// again it says the tree is up to
date. However with git:// it started downloading more things and tags.

That's confusing - I believed all protocols should behave the same way...?

Goo
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux