Re: GFS2 Filesystem [1/16]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi,

Thanks for the feedback and now added to out todo list along with your
earlier comments,

Steve.

On Sat, 2006-02-25 at 23:48 +0200, Pekka Enberg wrote:
> On 2/24/06, Steven Whitehouse <[email protected]> wrote:
> > +/*  Divide num by den.  Round up if there is a remainder.  */
> > +#define DIV_RU(num, den) (((num) + (den) - 1) / (den))
> 
> Seems generally useful. Consider putting this to <linux/kernel.h> and
> giving it a better name e.g. DIV_ROUND_UP.
> 
> > +#define get_v2sdp(sb) ((struct gfs2_sbd *)(sb)->s_fs_info)
> > +#define set_v2sdp(sb, sdp) (sb)->s_fs_info = (sdp)
> > +#define get_v2ip(inode) ((struct gfs2_inode *)(inode)->u.generic_ip)
> > +#define set_v2ip(inode, ip) (inode)->u.generic_ip = (ip)
> > +#define get_v2fp(file) ((struct gfs2_file *)(file)->private_data)
> > +#define set_v2fp(file, fp) (file)->private_data = (fp)
> > +#define get_v2bd(bh) ((struct gfs2_bufdata *)(bh)->b_private)
> > +#define set_v2bd(bh, bd) (bh)->b_private = (bd)
> > +
> > +#define get_transaction ((struct gfs2_trans *)(current->journal_info))
> > +#define set_transaction(tr) (current->journal_info) = (tr)
> > +
> > +#define get_gl2ip(gl) ((struct gfs2_inode *)(gl)->gl_object)
> > +#define set_gl2ip(gl, ip) (gl)->gl_object = (ip)
> > +#define get_gl2rgd(gl) ((struct gfs2_rgrpd *)(gl)->gl_object)
> > +#define set_gl2rgd(gl, rgd) (gl)->gl_object = (rgd)
> > +#define get_gl2gl(gl) ((struct gfs2_glock *)(gl)->gl_object)
> > +#define set_gl2gl(gl, gl2) (gl)->gl_object = (gl2)
> 
> Consider dropping these macros. Please note redundant casting.
> 
> > +#define gfs2_inum_equal(ino1, ino2) \
> > +       (((ino1)->no_formal_ino == (ino2)->no_formal_ino) && \
> > +       ((ino1)->no_addr == (ino2)->no_addr))
> 
> Consider using static inline function instead.
> 
> > +#define DT2IF(dt) (((dt) << 12) & S_IFMT)
> > +#define IF2DT(sif) (((sif) & S_IFMT) >> 12)
> 
> Ditto.
> 
>                                               Pekka

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux