Re: [PATCH 6/9] Cleanup kmem_cache_create()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Friday 11 November 2005 01:04, Matthew Dobson wrote:
> - if (size < 4096 || fls(size - 1) == fls(size - 1 + 3 * BYTES_PER_WORD))
> + if (size < RED_ZONE_LIMIT ||
> +	fls(size - 1) == fls(size - 1 + 3 * BYTES_PER_WORD))
>              flags |= SLAB_RED_ZONE|SLAB_STORE_USER;

I would suggest sth. like

if (size < RED_TONE_LIMIT
    || fls(size - 1) = fls(size - 1 + 3 * BYTES_PER_WORD))
	flags |= SLAB_RED_ZONE | SLAB_STORE_USER


Reason: A binary operator in front is a huge hint 
	that this is a continued line.

Just compare when you go to a store next time.

	1
+	2
-	3
*	4

is much more readable then

1	+
2	-
3	*
4

right?


Regards

Ingo Oeser


Attachment: pgpWm7MrDlAQT.pgp
Description: PGP signature


[Index of Archives]     [Kernel Newbies]     [Netfilter]     [Bugtraq]     [Photo]     [Stuff]     [Gimp]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Video 4 Linux]     [Linux for the blind]     [Linux Resources]
  Powered by Linux